Intermittent Availability Issues for Shared Cluster
Incident Report for Pagely
Resolved
The upgrade to PHP 7.2 has been completed. At this time, we think this issue is safe to resolve. We will mark it as such, and will continue to monitor behind the scenes.
Posted about 1 month ago. Dec 14, 2018 - 01:34 MST
Update
Our observations throughout the course of today have shown the shared servers running on PHP 7.2 have not been exhibiting any timeouts. Meanwhile, the servers using PHP 7.1 have shown transient moments of latency that self-recovered. These brief pauses do not appear to be related to high CPU or other resource usage. Our conclusion is that the activity occurring on some servers for certain sites is triggering a bug in PHP 7.1. We will proceed with upgrading all nodes in our shared cluster to PHP 7.2. This work will take place tonight over the next few hours.

During the upgrade process, all cacheable content, including your website pages, will continue to serve. Automatic failover mechanisms will ensure a backup server continues to process dynamic requests while each node briefly gets services stopped in order to change out the PHP 7 package.

As always, we will reach out to any customers whose sites fail our pre/post checks. This page will be updated once the work is completed.
Posted about 1 month ago. Dec 13, 2018 - 19:28 MST
Update
Our continued monitoring shows things have remained stable, however our investigation and work is still ongoing. We will keep this page open for the next 24 hours to continue providing updates as we see things through to a full resolution.
Posted about 1 month ago. Dec 13, 2018 - 00:10 MST
Monitoring
Things have remained stable following an emergency upgrade to PHP 7.2 for two nodes in the cluster. We are continuing to monitor all nodes and may take the same action of upgrading to 7.2 for other servers exhibiting problems, if we suspect it to be related to 7.1 .
Posted about 1 month ago. Dec 12, 2018 - 17:57 MST
Update
The nodes we switched back to 7.0 have been running without issues for the past few hours. We will be testing an upgrade to PHP 7.2 in the next few minutes to help narrow things down further.
Posted about 1 month ago. Dec 12, 2018 - 16:45 MST
Identified
We have identified a possible issue with the recent PHP 7.1 upgrade for certain web nodes. Although the change itself to 7.1 was successful, our health checks are identifying intermittent timeouts following the change. For the interim, we have rolled things back to PHP 7.0 for only a subset of sites. Our team is evaluating and monitoring the situation further.

It is possible that we may switch the affected group to PHP 7.2 in order to rule out a possible issue with PHP 7.1. While 7.1 is still receiving security updates, any potential bugs that are present in 7.1 that may be causing this would not be receiving upstream fixes. Thus, the path forward would be 7.2.

We'll keep you posted on this page as progress is made.
Posted about 1 month ago. Dec 12, 2018 - 11:53 MST
Investigating
Pagely engineers are investigating isolated reports of intermittent loading issues for certain segments of our shared hosting system. Not all customers on the shared cluster are affected. This does not affect any VPS plans.

We'll update this page as progress is made.
Posted about 1 month ago. Dec 12, 2018 - 11:09 MST
This incident affected: Shared Hosting Infrastructure.