Fastly is having an outage
Incident Report for Pagely
Resolved
Fastly status is reporting the incident as resolved: https://status.fastly.com/

Our monitoring does not show any sites still down due to the outage. As such we are marking this incident as resolved.
Posted Jun 08, 2021 - 06:22 MST
Monitoring
Fastly status page now shows "The issue has been identified and a fix is being implemented". Customers that use Fastly can monitor https://status.fastly.com/ for further updates. Our monitoring is not reporting any sites as being down at this time.
Posted Jun 08, 2021 - 03:56 MST
Investigating
Fastly appears to be having an outage. We are unable to load the main page from several locations and some client sites using Fastly are reporting down.

Fastly has posted an update on their status page saying that they're currently investigating the issue:
https://status.fastly.com/

Customers using Fastly may experience their sites being down at this time. Pagely hosting is unaffected.
Posted Jun 08, 2021 - 03:16 MST