Information For Pagely Customers regarding "Let's Encrypt - Revoking certain certificates on March 4"
Incident Report for Pagely
Resolved
This incident has been resolved.
Posted Mar 04, 2020 - 22:20 MST
Monitoring
At this time, all Let's Encrypt certificates issued from within our Atomic Control Panel have been checked. The small number of certificates we found to require a forced renewal have been fixed.

As an update from Let's Encrypt, revocations will officially commence at 2020-03-04 20:00 UTC (1:00pm US MST).

We will continue to monitor over the next 24 hours, however all certificates that we identified have been issued a forced renewal and are no longer affected.

To verify things yourself, you may go to https://checkhost.unboundtest.com/ and enter your domain name.
Posted Mar 04, 2020 - 00:37 MST
Identified
Our team has been investigating a matter relating to Let's Encrypt that was disclosed earlier today. The problem discovered by Let's Encrypt potentially affects anyone using certs issued by Let's Encrypt, not just websites running on Pagely.

Pagely's customers can provision free Let's Encrypt certificates using our Atomic Control Panel. We have been assessing whether any of those certificates provisioned by our system will be revoked on March 4, 2020. We are happy to report that the very small number of Let's Encrypt certificates for our customers found on the affected list have already been identified and steps have been taken to force a renewal on those certificates, or will be corrected within the next few hours before revocations start happening.

More information about this issue can be found on:

- The Status page for Let's Encrypt:
https://status.io/pages/incident/55957a99e800baa4470002da/5e5e9b5b144d9304c0e602c7

- The Let's Encrypt Community Forums: https://community.letsencrypt.org/t/revoking-certain-certificates-on-march-4/114864

We encourage all website owners to review the above links and check any other sites you do not have under Pagely, and take the appropriate steps to renew the affected certs. Just to reiterate, Pagely is already taking care of this verification and correction process on your behalf for sites hosted here.

This incident will be kept open until we are fully satisfied with our assessment and corrective steps.
Posted Mar 03, 2020 - 13:03 MST
This incident affected: VPS Hosting Infrastructure and Shared Hosting Infrastructure.