Intermittent issues with Support System (Zendesk)
Incident Report for Pagely
Resolved
This incident has been resolved.
Posted 5 months ago. Mar 07, 2018 - 15:22 MST
Investigating
Our Support (powered by Zendesk) is temporarily unavailable. Full details at https://status.zendesk.com/

You may see intermittent issues until things clear up.

We will update as the situation progresses.
Posted 5 months ago. Mar 07, 2018 - 15:07 MST