Subset of EC2 instances in AWS Virginia Experiencing Issues

Incident Report for Pagely

Resolved

This incident is now resolved.
Posted May 08, 2026 - 07:50 UTC

Monitoring

All affected instances are now restored and we continue to monitor for any issues.
Posted May 08, 2026 - 07:38 UTC

Update

We’ve restored several EBS volumes and brought associated EC2 instances back online; work is still in progress on the remaining instances, and we’ll share another update shortly.
Posted May 08, 2026 - 06:19 UTC

Update

A small number of instances still have an EBS-related issue we’re actively investigating, and all other instances, those not affected by this problem, have been back to normal for some time now.
Posted May 08, 2026 - 03:00 UTC

Update

A few hosts still show EBS volume issues that prevent a full restart; we are actively fixing those and continuing investigation alongside the broader recovery work.
Posted May 08, 2026 - 01:01 UTC

Identified

We have identified the affected EC2 instances in AWS. Reboots have been started on all of them while we continue to confirm recovery. Additional updates will be provided shortly.
Posted May 08, 2026 - 00:41 UTC

Investigating

We are investigating an issue affecting a subset of EC2 instances in AWS US East (Virginia). Those instances are temporarily unreachable while we determine root cause.
Posted May 08, 2026 - 00:05 UTC
This incident affected: VPS Hosting Infrastructure.