Payment Processor Issues

Incident Report for Pagely

Resolved

Our payment processor addressed the issue with failed transactions and this issue is now resolved.
Posted Dec 04, 2025 - 23:38 UTC

Investigating

We are currently investigating an issue with our payment processor preventing payments and affecting new sign-ups.
Posted Dec 04, 2025 - 22:54 UTC