Support platform outage
Incident Report for Pagely
Resolved
This incident has been resolved.
Posted 3 months ago. Jul 02, 2019 - 07:20 MST
Investigating
We are currently investigating an issue affecting access to our support platform and live chat.
Posted 3 months ago. Jul 02, 2019 - 07:03 MST
This incident affected: Support System.