Payment Processor Issues

Incident Report for Pagely

Resolved

The issue with the payment processor has been fixed and this issue is now resolved.
Posted Nov 26, 2025 - 01:36 UTC

Update

We continue to work with our payment processor on a resolution and will post further updates when we have more information.
Posted Nov 25, 2025 - 22:10 UTC

Update

We are in contact with our payment processor and will provide further updates shortly.
Posted Nov 25, 2025 - 18:26 UTC

Investigating

We are currently investigating an issue with our payment processor preventing payments and affecting new sign-ups.
Posted Nov 25, 2025 - 15:56 UTC