Atomic new registration errors

Incident Report for Pagely

Resolved

New account signup issues are now resolved.
Posted Feb 10, 2026 - 15:54 UTC

Investigating

Our team is aware of an issue that is impacting new account and new plan registrations in Atomic. We are actively investigating.
Posted Feb 10, 2026 - 04:03 UTC
This incident affected: Atomic Control Panel.